Elevated Manual Sync Errors

Incident Report for Miter

Resolved

Reports have indicated this issue is resolved.
Posted Feb 24, 2026 - 21:09 UTC

Monitoring

We are experiencing elevated reports of manual syncs failing to trigger. We have released and deployed a fix to all customers, and we are now monitoring it to ensure it is working as intended.
Posted Feb 24, 2026 - 19:35 UTC
This incident affected: Miter Platform.